Jump to content
Sign in to follow this  
Edd

Auto-Hunting Target Changing Speed

Recommended Posts

Edd    18

Hello GMs and fellow L2 Players,

 

I've noticed a significant slow down in the auto-hunting targeting.
This is what I've noticed

POST newest update,

Upon killing a monster, the auto-hunting executes the macro one more time to the dead monster until recognizing that it's dead, resulting in "Invalid target." system message. This results in about 1-2s delay after killing a mob which accumulates in a lot of time lost due to this slow down.

PRE newest update,

Upon killing a monster, the auto-hunting system recognizes that the monster is already dead without executing extra macro command, thus never got "Invalid target" message, the macro selected a new target immediately upon the monster's death. Much more effective than what auto-hunting is now after the update.

 

Please look into the issue as this gives too big of a benefit to players using 3rd party programs to EXP.

 

Regards,

iEddie

Share this post


Link to post
Share on other sites
Royo    1
9 hours ago, Edd said:

Hello GMs and fellow L2 Players...

My assist macro has always been sluggish if I don't have the window "active". I can't for example watch youtube or something like that because then every row in the macro will take 2 seconds or more. This is probably not related but I just wanted to point out that the macro system is not so good.

Share this post


Link to post
Share on other sites
Edd    18

@Royo
Hey, I'm not using an assist macro but instead a 1 line macro of "/useskill Aqua Swirl"  which should result in no delay at all. Also I have my game open, nothing in the background.

It's seems like nothing much but it adds up to about 3b exp less per day.

I would really appreciate if the GMs look into that and see if they can adjust the auto next target more efficiently.

Share this post


Link to post
Share on other sites
mixa    498

This is actually a undocumented change, probably made to reduce client-server delay or spam. It's the same on the live servers.

Share this post


Link to post
Share on other sites
mixa    498
13 hours ago, Ingwaz said:

Fix this if unintended please.

If mixa is right, well fair enough... if not, its annoying :)

Please note that this is only my opinion, but it's the same on innova's servers. It might be a bug, but to me it seems rather intentional, since before that you were changing targets faster than a bot.Also I've seen this on the Korean servers, so there is a high chance this to be just a tone down of this feature.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×