Jump to content
Sign in to follow this  
Manza

Auto-attack disabling after a while

Recommended Posts

Manza    0

My auto attack tool is not working properly, it gets disabled after a while... I have noticed this happen specifically when I auto-attack with my archer, other than that if only my melees are attacking this won't happen. So basically if I enable my auto-attack tool with my archer, suddenly and after a while I keep getting these "teleport auras" on my characters and every time that happens it gets disabled. its very annoying... anyone else having this issue? any ideas? solution? 

Thanks !

Share this post


Link to post
Share on other sites
Wilma    0

Hi, I seen same problem at Cuma lvl 2, when I'm stucked. I changed spot, and all was good.

Share this post


Link to post
Share on other sites
Semti    2

The only solution to this, for now, is to have another char out of combat picking the targets. Then, just assist them.

Warcryer is a good choice - just have buffs and delay in auto window.

Doing this can also help you to auto within a set area.. don't need to worry about drifting to some pker's spot or walking over to a raid boss

 

GL!

  • Like 2

Share this post


Link to post
Share on other sites

There are a few ways this can occur. Sometimes just switching away from the auto attack client can cause the auto attack to break. The solution is to switch to another client make sure things are working for at least 3 mobs then move on.

Another way this can break is that when there are two lineage 2 clients overlapping sometimes commands from the top/active window can click through to the window below which can disrupt the auto attack on the hidden window.  I've managed to rotate the camera on multiple lineage 2 clients simultaneously via this "bug".

Then the last way I've observed has no real explanation. I've had auto hunt just stop on it's own on an unattended machine without any form of input (no mouse swing even). It's super rare but it does happen.

Share this post


Link to post
Share on other sites

@Manza Is this happening to you in Cruma Tower? if so, @Wilma too, it may be when you fight the mob: Perum https://l2wiki.com/classic/Perum

These guys have an ability that teleports you, and as a result it turns off your auto attack/macro. They do leave a visual teleport aura around you after they do it, so I'm thinking this is what is happening to you.

Fortunately I think that @Semti's genius solution may be a way to get around this.
I'm definitely going to try it next time I'm there :D

Share this post


Link to post
Share on other sites
Gazob1    16
On 25/11/2019 at 9:26 AM, Semti said:

The only solution to this, for now, is to have another char out of combat picking the targets. Then, just assist them.

Warcryer is a good choice - just have buffs and delay in auto window.

Doing this can also help you to auto within a set area.. don't need to worry about drifting to some pker's spot or walking over to a raid boss

 

GL!

This strategy is really decent, I used it a lot, but it has a big problem that should be considered, you have to find self contained respawn spots and they're hard to find, so that mobs don't stack outside of your assist radius. My biggest problem with the auto-hunt is the characters that are following your lead will eventually get stuck on trees and you'll die, so you also have to manage to find spots such as Cruma that are naturally self contained. NCSoft could do some work with the respawns to make auto-hunt a bit better, but not overdoing like they did with L2 Essence making the game feel completely artificial, just to a point where trees don't become a problem or mobs stacking outside your hunt perimeter. Another advice for anyone using auto assist is to turn off "optimize performance" in options so that your characters run the macro way way faster. (optimizing the performance will make the client use very very low CPU but it make the macros slow up to a point where some skills can't be used such as targeting something and casting fast enough if you're auto-hunting). I really wish that NCSoft also had considered your party not become part of the manner mode, your characters inside your party will stop to attack the target if the manner mode is on, this is really lackluster, you have to KS anyone if you wanna make the auto assist combo strategy, or find a spot that you're alone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×