Jump to content
Forums

Rudolph Agathion (Event)


Recommended Posts

1 hour ago, Sharlanna said:

So I equipped my Rudolph Agathion tonight that I've had for years and he no longer gives buffs. WTF... it use to. Seems like every time I log into this game these days the devs take the fun out of one thing or another and it sucks!

If it is indeed the old one, it must be out for at least 20 minutes before it will buff.

If it is the new one, it won't buff you.

Link to post
Share on other sites
14 minutes ago, Taunt said:

If it is indeed the old one, it must be out for at least 20 minutes before it will buff.

If it is the new one, it won't buff you.

She obviously said, that she had it for years, the old one. I might try mine to see if it buffs.

Link to post
Share on other sites
2 hours ago, Taunt said:

If it is indeed the old one, it must be out for at least 20 minutes before it will buff.

If it is the new one, it won't buff you.

I didn't leave it out for 20 minutes and logged out. Now when I ltry and log back in I'm facing big time lag/latency issues once again and have to force quit before eventually DCing. I sent a support ticket in yesterday and after them having me run HiJackThis and WinMRT they came back with the usual response saying the devs are aware of the latency issues and are working to resolve the issue. This is such BS! It definitely appears to be regional. The WinMRT exe file basically runs a traceroute after logging into L2 and running the app.

Link to post
Share on other sites
7 hours ago, Sharlanna said:

I didn't leave it out for 20 minutes and logged out. Now when I ltry and log back in I'm facing big time lag/latency issues once again and have to force quit before eventually DCing. I sent a support ticket in yesterday and after them having me run HiJackThis and WinMRT they came back with the usual response saying the devs are aware of the latency issues and are working to resolve the issue. This is such BS! It definitely appears to be regional. The WinMRT exe file basically runs a traceroute after logging into L2 and running the app.

You didn't logged in long enough for the Rudolph Agathion to kick in.  So I guess it still works.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...