Jump to content
Sign in to follow this  
Lean

Hurricane shackle lvl 2

Recommended Posts

Lean    96

It is bugged since the arrival of tales untold?

I have the Ap for revelation skills lvl 2, but when i use the buff wont pop up like savage.

 

Patk also dnt rise.

Share this post


Link to post
Share on other sites
Draecke    517

works fine for me, the buff will show next to your buff potions etc bar - 3rd one on the below screenshot

o3ytXet.png

  • Like 1

Share this post


Link to post
Share on other sites
Helvie    67

I only noticed that disparition changed cooldown from 5 minutes to 10 minutes, wasn't mentioned in patch notes.

  • Like 1

Share this post


Link to post
Share on other sites
Lean    96
2 hours ago, Draecke said:

works fine for me, the buff will show next to your buff potions etc bar - 3rd one on the below screenshot

o3ytXet.png

Yes not showing to me, first time i get the savage and unbind, and reset to get shakle, but the buff wont pop up and my patk and dnt rise, but i dnt restart the game yet, i doubt but maybe i need do that, going to check that soon and if it works i will came back here.

 

Just saying again i have the ap for revelation skills lvl 2. mb is some glitch for reset skills and get this one not sure. Hope it works, thanks for the img btw.

Share this post


Link to post
Share on other sites
dvpKAKdcp    7
1 hour ago, Helvie said:

I only noticed that disparition changed cooldown from 5 minutes to 10 minutes, wasn't mentioned in patch notes.

Always 10 min 6 min cd with full buff no cd talisman etc

Share this post


Link to post
Share on other sites
Lean    96
3 hours ago, Draecke said:

works fine for me, the buff will show next to your buff potions etc bar - 3rd one on the below screenshot

o3ytXet.png

Draecke and all who take a time to help me, when i re start the game it start to work the skill, ty all. 

After reset your revelation skills, at least for me you need restart the game to make it work. thanks again.

Share this post


Link to post
Share on other sites
bentorero    19

yes restart solves this issue. try entering dim server and port out using the gatekeeper... u will be bugged again. 

can someone else try pls? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×