Jump to content

soulshots don't work


Recommended Posts

The soulshots do not work for me, they cannot be used with my tyrr titan I have tried with the commons, event and misterious shoulshots and even so it tells me that I do not have and I can not equip them, only those of magicians are equipped. ... I hope to make a solution and be able to log in at least 4 accounts.Shot00002.png

Link to comment
Share on other sites

3 hours ago, Nymphadorae said:

I had this problem too, but the launcher update from yesterday solved it. Try to close everything, update launcher and try again ;)

It fixed the spiritshots on one of my toons but now I have issues with the fishing shots on another toon. Seems like something's still wrong.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...